Multiplayer Service Outage
Incident Report for SNOW
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 26, 2016 - 03:24 CET
Monitoring
Our servers should be back up now.
Posted over 1 year ago. Mar 26, 2016 - 03:16 CET
Investigating
We're investigating an issue with our multiplayer servers.
Posted over 1 year ago. Mar 26, 2016 - 02:54 CET