Oceania Mutliplayer Servers Down
Incident Report for SNOW
Resolved
The issue has been resolved, and all systems are healthy.
Posted about 1 year ago. Oct 03, 2016 - 22:19 CEST
Investigating
We're currently seeing issues with our Oceania MP servers, and are investigating the cause.
Posted about 1 year ago. Oct 03, 2016 - 22:08 CEST