Multiplayer Incident
Incident Report for SNOW
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 29, 2016 - 20:25 CEST
Monitoring
Our multiplayer server management system had a small hiccup, that caused the wrongful down-scaling of all the running servers. We've fixed the issue and are monitoring.
Posted over 1 year ago. Mar 29, 2016 - 19:37 CEST