Europe server unavailability
Incident Report for SNOW
Resolved
All regions are fully functional now, and service is back to normal.
Posted about 1 year ago. Mar 30, 2016 - 15:56 CEST
Identified
Servers are coming back up.
Posted about 1 year ago. Mar 30, 2016 - 15:44 CEST
Investigating
European servers are currently unavailable due to work on releasing the new 0.7.1 game update.
Posted about 1 year ago. Mar 30, 2016 - 15:10 CEST