Delayed Player Information Handling
Incident Report for SNOW
Resolved
Our upstream issues have been resolved, and our servers have been able to process the data. Everything is back to normal.
Posted about 1 month ago. Jan 11, 2018 - 16:59 CET
Monitoring
We're currently experiencing upstream issues, preventing our servers from scaling to handling some data sent to them in a timely fashion. All data is safe, and will be handled as soon as we no longer have upstream issues.

We've also started implementing a local cache to prevent similar issues in the future.
Posted about 1 month ago. Jan 11, 2018 - 16:42 CET